Flutter Study Jam / Hands On Session

About this event

Laptops Required to follow along!

Flutter is Google’s portable UI kit for crafting high-quality native interfaces on iOS and Android in record time. Flutter works with existing code, is used by developers and organizations around the world, and is free and open source.
Want to get started on building Flutter apps?
Join us for our Flutter Study Jam! Together we'll work through Flutter codelabs prepared by Google instructors. You will be able to get hands-on experience with Flutter and build a Flutter app while learning the fundamentals..

Bring a laptop! The course will run on all of the latest versions of the popular browsers. For the best experience, the laptop should have Flutter installed on it prior to starting the study jam to save time. Windows/Linux/Mac would all be fine. Check out : https://flutter.dev/docs/get-started/install

We are going to have a hands on workshop for flutter. Each attendee must bring their laptop (minimum requirements at the bottom). we will go through the setup together so you don't need to do anything at home.

Food and drinks will be provided!

Prior to the event please join https://join.slack.com/t/gdghalifax/shared_invite/enQtNzExNjM2MTc5MjIxLTU5ZTg2ZTY4OTQ0ZGQ2ODNmNjRlN2ZhNzRkMWIxM2U1MzYxYzM4ODg0N2RhOGNkMTNmZGNkYTdiYTAwNTU0OGQ so we can share links and files during the event.

Agenda:
04:00 PM Registrations
04:15 PM Introductions
04:20 PM Setup and connecting to the (Instructors) screen share session
04:30 PM What's Flutter ? - Shereef Marzouk
05:00 PM Hands On Session
06:00 PM Questions
06:15 PM Closing raffle and swag for the winner(s)

Laptops Required to follow along!

Wifi is available in the Sobeys community room.

P.S. This Venue doesn't have a projector so we will have to setup a screen share session where attendees will see the instructor's laptop.

Windows:
Operating Systems: Windows 7 SP1 or later (64-bit)
Disk Space: 400 MB (does not include disk space for IDE/tools).
Tools: Flutter depends on these tools being available in your environment.
Windows PowerShell 5.0 or newer (this is pre-installed with Windows 10)
Git for Windows 2.x, with the Use Git from the Windows Command Prompt option.

If Git for Windows is already installed, make sure you can run git commands from the command prompt or PowerShell.

Linux:
System requirements
To install and run Flutter, your development environment must meet these minimum requirements:

Operating Systems: Linux (64-bit)
Disk Space: 600 MB (does not include disk space for IDE/tools).
Tools: Flutter depends on these command-line tools being available in your environment.
bash
curl
git 2.x
mkdir
rm
unzip
which
xz-utils
Shared libraries: Flutter test command depends on this library being available in your environment.
libGLU.so.1 - provided by mesa packages such as libglu1-mesa on Ubuntu/Debian

Mac:
System requirements
To install and run Flutter, your development environment must meet these minimum requirements:

Operating Systems: macOS (64-bit)
Disk Space: 700 MB (does not include disk space for IDE/tools).
Tools: Flutter depends on these command-line tools being available in your environment.
bash
curl
git 2.x
mkdir
rm
unzip
which


Organizers

  • Shereef Marzouk

    Shereef Marzouk

    DaySmart Software Inc.

    GDG Organizer / Founder

    View Profile
  • Radwa Mohamed

    Radwa Mohamed

    Co-Founder

    View Profile
  • Hadear Marzooque

    Hadear Marzooque

    H.M. Immigratr

    Talent & Immigration Consultant

    View Profile